Tuesday, April 26, 2011

Eclipse Forums upgrade gone bad.

A few weeks ago I set out to upgrade our aging Forums software. We're about 1.5 years behind the latest release, and with numerous bugfixes and new features, an upgrade seemed compelling. For instance, here are some of the things we're missing:

  • Per-forum search. Because of the size of our forums (650,000+ messages), the single database server would be crushed by the search queries.
  • Single database server. The current version only supports a single server, limiting scalability and preventing us from enabling search.
  • Broken NNTP bridge. Our forums are linked to the NNTP newsgroups, and attachment import/export is broken, as are many extended character sets.

Despite my best efforts, the upgrade failed miserably and I reverted back to the old version. The software we use, FUDForum, is a decent piece of code, but it has a rather unorthodox way of doing templates and themes, which leads to it being easily broken on our rather restricted multi-server PHP environment. When I set it up almost 2 years ago, I had to twist and contort it to fit. The result was a brittle piece of software that did what it is supposed to, as long as you walked on eggshells when managing it.

On the bright side, a brand-new install of the same software works like a charm on eclipse.org, without any of the previous twisting and contorting needed, and it simply feels more robust. I guess 2 years of development will do that to software. There's just something with the upgrade process + our hacked version that simply doesn't jive.

All told, we cannot simply continue using the current version. It works, but with many broken parts, and with many security holes now patched, it needs fixing. I can think of two options:
  • Option 1: Move to a different forum software. This would break links to all the existing messages, present a new UI to our users and would put us webmasters in unfamiliar territory by discarding the two years of knowledge we've accumulated with FUDForum.

  • Option 2: Install the new version from scratch, and re-import all the NNTP messages. This would also break links to existing messages, but it is known to work on our servers, and FUDForum (although not perfect by any means) is now well understood by the webmasters.
What is your take? Feel free to discuss with us on bug 342708.

0 Comments:

Post a Comment

<< Home